منتديات قصة حب غرامية

شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 44469110

منتدى ,شامل,صور,افلام,جريمة,عالم البلوتوث،برامج مجانية ،تطوير مواقع

                                
  

شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك

love tale
love tale
المدير العام
المدير العام

تاريخ التسجيل تاريخ التسجيل : 22/08/2008
عدد المساهمات عدد المساهمات : 5244
العمر العمر : 35
المزاج المزاج : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 95v19777
الجنس الجنس : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك T5260310
الدولة الدولة : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Eg10
نقاط نقاط : 13132
السٌّمعَة السٌّمعَة : 4
احترام قوانين المنتدى : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 111010
الاوسمةشرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Pb9bol10
اوسمة2شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 16

شرح شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك

مُساهمة من طرف love tale في الإثنين 17 أغسطس 2009, 7:59 pm

شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 60xg3

شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك F%20%2870%29



ناس كتير اوى بتسأل عن طريقه دمج خطين .. وجاتلى اكتر من رساله بتطلب الطريقه

فقلت اعمل موضوع شامل ليها بأذن الله

الاول يا جماعه لازم نبقى متفقين مافيش حاجه اسمها دمج خطين

كله عباره عن توزيع احمال .. وده بيختلف من طريقه لطريقه تانيه .

منتديات قصة حب غرامية

فى طريقه بتعتمد على انها تعمل توزيع احمال بين الخطين عن طريق البينج ( فبالتالى بيسحب من كل خط بالتساوى لحد ما يساوى البينجين بينهم )
ولو انت بتحمل ببرنامج تحميل ( دونلود مانجر , تورنت , الخ ) هتسحب بسرعه الخطين ودى اللى بتقولوا عليها دمج خطين

منتديات قصة حب غرامية
وطريقه تانيه بتعمتد على توزيع كل مستخدم على خط بمعنى ان السيرفر اوتوماتيك بيوزع محمود على الخط الاول .. محمد على الخط التانى .. وهكذا .. وده طبعا عن طريق الاى بى بتاعه
( وبيعكس الناس دى كل 24 ساعه )

منتديات قصة حب غرامية
وان شاء الله انا هشرح الطريقتين اللى متوفرين حاليا ( فى طريقه تالته بتتعمل .. بس لسه ما خلصتش اول ما تنزل هقولكم عليها بأذن الله )


منتديات قصة حب غرامية
نبدأ بطريقه توزيع الاحمال عن طريق البينج
( اسمها فى الموسوعه بتاعت مايكروتيك ECMP )


هنفترض ان عندنا روترتين
الاول الاى بى بتاعه 192.168.0.1
التانى الاى بى بتاعه 192.168.1.1
واى بى الخروج للمشتركين 192.168.100.1

اولا : بتسمى الكروت كالتالى

كارت الخروج Local
كارت الدخول من الروتر الاول WAN1
كارت الدخول من الروتر التانى WAN2

وبتظبط الاسكريبت ده وبتحطه :

/ ip address
add address=XXX.XXX.XXX.XXX/24 network=XXX.XXX.XXX.0 broadcast=XXX.XXX.XXX.255 interface=Local
add address=YYY.YYY.YYY.YYY/24 network=YYY.YYY.YYY.0 broadcast=YYY.YYY.YYY.255 interface=WAN1
add address=ZZZ.ZZZ.ZZZ.ZZZ/24 network=ZZZ.ZZZ.ZZZ.0 broadcast=ZZZ.ZZZ.ZZZ.255 interface=WAN2

XXX.XXX.XXX.XXX = اى بى الخروج للشبكه بتاعتك ( 192.168.100.1 )
XXX.XXX.XXX = اى بى الخروج للشبكه بتاعتك محذوف منه اخر رقم ( 192.168.100 )

YYY.YYY.YYY.YYY = اى بى الدخول من الروتر الاول ( 192.168.0.5 )
YYY.YYY.YYY = اى بى الدخول من الروتر التانى محذوف منه اخر رقم ( 192.168.0 )

ZZZ.ZZZ.ZZZ.ZZZ = اى بى الدخول من الروتر التانى ( 192.168.1.5 )
ZZZ.ZZZ.ZZZ = اى بى الدخول من الروتر التانى محذوف منه اخر رقم ( 192.168.1 )

/ ip route
add dst-address=0.0.0.0/0 gateway=Router1 IP,Router2 IP check-gateway=ping


Router1 IP,Router2 IP = اى بى كل من الروتر الاول والروتر التانى ( 192.168.1.1,192.168.0.1 )

/ ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/ ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=Conn#1
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=Conn#2
add chain=output connection-mark=Conn#1 action=mark-routing new-routing-mark=To_Conn#1
add chain=output connection-mark=Conn#2 action=mark-
routing new-routing-mark=To_Conn#2


/ ip route
add dst-address=0.0.0.0/0 gateway=Router1 IP routing-mark=To_Conn#1
add dst-address=0.0.0.0/0 gateway=Router2 IP routing-mark=To_Conn#2


Router1 IP = اى بى الروتر الاول ( 192.168.0.1 )

Router2 IP = اى بى الروتر التانى ( 192.168.1.1 )

وده اسكريبت جاهز على الافتراض اللى قلناه فى الاول :
كود:
/ ip address
add address=192.168.100.1/24 network=192.168.100.0 broadcast=192.168.100.255 interface=Local
add address=192.168.0.5/24 network=192.168.0.0 broadcast=192.168.0.255 interface=WAN1
add address=192.168.1.5/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN2

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.0.1,192.168.1.1 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/ ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=Conn#1
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=Conn#2
add chain=output connection-mark=Conn#1 action=mark-routing new-routing-mark=To_Conn#1
add chain=output connection-mark=Conn#2 action=mark-routing new-routing-mark=To_Conn#2

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=To_Conn#1
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=To_Conn#2


منتديات قصة حب غرامية

الطريقه دى فيها مشاكل :
وهيا ان بيحصل تقطيع فى الانترنت كل 10 ل 50 دقيقه

ودى مشكله بسبب النواه بتاعت اللينوكس ( اللى قايم عليها نظام المايكروتيك كله )

وبسب التقطيع ده الميل بيقطع ( الياهو , الهوت ميل , الاسكاى بى , الخ )
وكمان التحميل بيقطع ....

هتقولى ممكن نتغلب على مشكله المسنجرات عن طريق اننا نحددهم على روتر معين دايما ... هقولك اوكى هتحل المشكله ..

ودى اكوادها اهه :
كود:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="Y! routing mark" disabled=\
no dst-port=5050 new-routing-mark=Yahoo passthrough=no protocol=tcp
add action=mark-routing chain=prerouting comment="MSN routing mark" disabled=\
no dst-port=1863 new-routing-mark=MSN passthrough=no protocol=tcp
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.0.1 routing-mark=MSN scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.0.1 routing-mark=Yahoo scope=30 target-scope=10
منتديات قصة حب غرامية

طيب ومشكله التحميل ؟

افرض انه بيحمل من موقع زى رابيد شير مافيهوش استكمال ؟ كده عمره ما هيحمل ملف من اول مره .. بالعكس ممكن يقعد يوم كامل على ما يحمل ملف واحد .

طيب ليه شرحت الطريقه دى .. لان كل الناس بتسأل عن الطريقه دى تحديدا . قلت اشرحها وكل واحد حر .



تم بحمد الله الطريقه الاولى ,
الطريقه التانيه فى المشاركه القادمه





شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Jkghj10
love tale
love tale
المدير العام
المدير العام

تاريخ التسجيل تاريخ التسجيل : 22/08/2008
عدد المساهمات عدد المساهمات : 5244
العمر العمر : 35
المزاج المزاج : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 95v19777
الجنس الجنس : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك T5260310
الدولة الدولة : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Eg10
نقاط نقاط : 13132
السٌّمعَة السٌّمعَة : 4
احترام قوانين المنتدى : شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 111010
الاوسمةشرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Pb9bol10
اوسمة2شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك 16

شرح رد: شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك

مُساهمة من طرف love tale في الإثنين 17 أغسطس 2009, 8:01 pm

الطريقه التانيه :
توزيع الاحمال عن طريق الادريسس ليست ( كل مستخدم على خط )
اسمها فى الموسوعه بتاعت مايكروتيك NTH



هنفترض ان عندنا روترتين
الاول الاى بى بتاعه 192.168.0.1
التانى الاى بى بتاعه 192.168.1.1
واى بى الخروج للمشتركين 192.168.100.1

اولا : بتسمى الكروت كالتالى

كارت الخروج Local
كارت الدخول من الروتر الاول WAN1
كارت الدخول من الروتر التانى WAN2


/ ip address
add address=XXX.XXX.XXX.XXX/24 network=XXX.XXX.XXX.0 broadcast=XXX.XXX.XXX.255 interface=Local
add address=YYY.YYY.YYY.YYY/24 network=YYY.YYY.YYY.0 broadcast=YYY.YYY.YYY.255 interface=WAN1
add address=ZZZ.ZZZ.ZZZ.ZZZ/24 network=ZZZ.ZZZ.ZZZ.0 broadcast=ZZZ.ZZZ.ZZZ.255 interface=WAN2

XXX.XXX.XXX.XXX = اى بى الخروج للشبكه بتاعتك ( 192.168.100.1 )
XXX.XXX.XXX = اى بى الخروج للشبكه بتاعتك محذوف منه اخر رقم ( 192.168.100 )

YYY.YYY.YYY.YYY = اى بى الدخول من الروتر الاول ( 192.168.0.5 )
YYY.YYY.YYY = اى بى الدخول من الروتر التانى محذوف منه اخر رقم ( 192.168.0 )

ZZZ.ZZZ.ZZZ.ZZZ = اى بى الدخول من الروتر التانى ( 192.168.1.5 )
ZZZ.ZZZ.ZZZ = اى بى الدخول من الروتر التانى محذوف منه اخر رقم ( 192.168.1 )


/ ip firewall mangle
add chain=prerouting src-address-list=odd in-interface=Local action=mark-connection new-connection-mark=odd passthrough=yes
add chain=prerouting src-address-list=odd in-interface=Local action=mark-routing new-routing-mark=odd passthrough=no
add chain=prerouting src-address-list=even in-interface=Local action=mark-connection new-connection-mark=even passthrough=yes
add chain=prerouting src-address-list=even in-interface=Local action=mark-routing new-routing-mark=even passthrough=no
add chain=prerouting in-interface=Local connection-state=new nth=2,1 action=mark-connection new-connection-mark=odd passthrough=yes
add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=odd address-list-timeout=1d connection-mark=odd passthrough=yes
add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no
add chain=prerouting in-interface=Local connection-state=new nth=2,2 action=mark-connection new-connection-mark=even passthrough=yes
add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=even address-list-timeout=1d connection-mark=even passthrough=yes
add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no

/ ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/ ip route
add dst-address=0.0.0.0/0 gateway=Router1 IP scope=255 target-scope=10 routing-mark=odd
add dst-address=0.0.0.0/0 gateway=Router2 IP scope=255 target-scope=10 routing-mark=even
add dst-address=0.0.0.0/0 gateway=Router1 IP scope=255 target-scope=10



Router1 IP = اى بى الروتر الاول ( 192.168.0.1 )

Router2 IP = اى بى الروتر التانى ( 192.168.1.1 )


وده اسكريبت جاهز على اساس الافتراض اللى قلناه :

كود:
/ ip address
add address=192.168.100.1/24 network=192.168.100.0 broadcast=192.168.100.255 interface=Local
add address=192.168.0.5/24 network=192.168.0.0 broadcast=192.168.0.255 interface=WAN1
add address=192.168.1.5/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN2

/ ip firewall mangle
add chain=prerouting src-address-list=odd in-interface=Local action=mark-connection new-connection-mark=odd passthrough=yes
add chain=prerouting src-address-list=odd in-interface=Local action=mark-routing new-routing-mark=odd passthrough=no
add chain=prerouting src-address-list=even in-interface=Local action=mark-connection new-connection-mark=even passthrough=yes
add chain=prerouting src-address-list=even in-interface=Local action=mark-routing new-routing-mark=even passthrough=no
add chain=prerouting in-interface=Local connection-state=new nth=2,1 action=mark-connection new-connection-mark=odd passthrough=yes
add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=odd address-list-timeout=1d connection-mark=odd passthrough=yes
add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no
add chain=prerouting in-interface=Local connection-state=new nth=2,2 action=mark-connection new-connection-mark=even passthrough=yes
add chain=prerouting in-interface=Local action=add-src-to-address-list address-list=even address-list-timeout=1d connection-mark=even passthrough=yes
add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no

/ ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.0.1 scope=255 target-scope=10 routing-mark=odd
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark=even
add dst-address=0.0.0.0/0 gateway=192.168.0.1 scope=255 target-scope=10



وبكده اكون شرحت الطريقتين المتوفرين حاليا .

الطريقه التانيه شغاله بكفاءه عاليه جدا .. وانا اشتغلت عليها مده كبيره ( قبل ما اوقف الخط التانى لظروف خاصه )
وكنت مفعل معاها الكاش وكانت كل حاجه شغاله زى الفل .

وان شاء الله اول ما الطريقه التالته تنزل هجربها وارفعهالكم هنا .





شرح :طرق توزيع احمال ( دمج خطين ) فى المايكروتيك Jkghj10

    الوقت/التاريخ الآن هو الثلاثاء 18 يونيو 2019, 6:06 pm